Beesource Beekeeping Forums banner

First ever package install...

2331 Views 11 Replies 6 Participants Last post by  ekervina
This past Saturday we got our first package of bees. This is the first installation we've ever done, but I think it went pretty well. We took our time, reviewed the entire process we were going to follow (step-by-step) twice, and then did it. There were a couple of things I think could have been done better, and if we do any future package installs, they will be. My intention is to (as much as possible) use nucs and splits from here on, so this may be the last package install I do...

My wife took photos and put them up on Flickr. If you aren't familiar with the service, Flickr always puts the newest pictures at the top, so you'll want to click through to the last page and start at the bottom right.

http://www.flickr.com/photos/[email protected]/
1 - 1 of 1 Posts

· Registered
Joined
·
44 Posts
Nice photos. I have a question though. I have bees coming this weekend and have my hives already situated on blocks. I will be using all mediums and just have one medium in place for the package of bees (each hive). I notice you used two to start with. Is this necessary? I was under the impression that one medium was enough to start with. It's coming down to the wire now and I starting to wonder if I've got everything ready.
Thanks
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top